
 

Release Notes for Omada SDN Controller V6.0  

Version Info  

The Controller version is fully compatible with the Omada app version 5.0.x.

Supported Device Models  

    For the device models Omada Software Controller supports, you can refer to: Omada Cloud 
SDN Platform Compatibility List

1. Added support for Access Points: EAP 787 v1.0

2. Added support for Gateways: ER701-5G-Outdoor v1.0, DR3650v(EU)1.20, ER706W-4G(EU)2.20, 
ER706WP-4G(EU) 1.20, ER706WP-4G(US)1.26, ER8411(UN)1.20, DR3220v-4G(EU)1.20, 
DR3650v-4G(EU)1.20, ER7206(UN)2.30, ER7406(UN)1.20, ER706W(EU/US)1.30, ER706W-
4G(US)1.30, ER605(UN)2.30, ER707-M2(UN)1.30, ER7412-M2(UN)1.30

3. Added support for OLTs: DS-MCUA

New Features  

1. Added support for displaying VLAN information, offline devices, and isolated devices in the 
topology view in Site View > Dashboard > Topology. 

2. Optimized the Client list by adding support for offline clients, enhancing the advanced search 
capabilities for both online and offline clients, and introducing a new unified export feature in 
the top-right corner of the Client list. Additionally, the Past Connection page has been 
removed from Insights, and detailed client connection information can now be viewed in the 
Connection Logs section of the Client details page. The Known Client page has been removed, 
and all clients can now be directly viewed in Site view > Clients > All.

3. Optimized Client Details layout with new Overview, Statistics, Connection Logs, Tools, and 
Config tabs in Site > Clients > Client Details.

4. Added support for a client online-timeline in the Client Details view in Site View > Client > 
Overview.
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5. Added support for a Connection Logs timeline in Site View > Client > Connection Logs.

6. Added support for Traffic, RSSI, Rate, and Speed trend charts in Site View > Client > 
Overview, gated by the Data Trend Record toggle.

7. Added support for the Data Trend Record switch in Global View > Settings > History Data 
Retention to control client-level metrics.

8. Optimized wireless client on/off-line detection for AP6.0 firmware, reducing controller 
notification latency to 0-5 seconds (TCP port 29817 required).

9. Added support for wireless client device-type, vendor, model, OS, and version identification in 
Global > Settings > Controller Settings > Services, with results shown in the Client List and 
Details pages (AP 6.0 firmware, Cloud Access and TCP port 29817 required).

10. Added support for LAN Isolation configuration, a new VLAN setting designed for networks 
where an Omada Gateway serves as the DHCP Server Device, enabling segment isolation and 
editing based on this configuration in Site > Network Config > LAN > Isolation Settings and 
in Site > Network Config > LAN > VLAN > Add/Edit for Gateway devices running firmware 
version 5.15.

11. Added support for a topology link diagram in Device > Device Details > Overview.

12. Added support for an online/offline timeline in Device > Device Details > Overview.

13. Optimized Device Details layout with new log and tool modules in Device > Device Details.

14. Optimized EAP/Bridge AP Details layout with updated config and statistics modules in Device 
> AP Details, and fixed mesh traffic chart accuracy in Device > AP Details > Statistics.

15. Optimized Switch Details layout with expanded statistics and streamlined config access in 
Device > Switch Details.

16. Optimized Gateway Details layout with new network view and config modules, plus added 
SIM and Transmission settings, in Device > Gateway Details.

17. Optimized OLT Details layout with additional data charts in Device > OLT Details; added 
Management System Interface configuration under Device > OLT Details > Config > System 
> Central Management and streamlined config entries for ARP table and interface. 

18. Added support for OUI-Based VLAN on Switch 6.0 firmware in Site > Network Config > 
Transmission > OUI Based VLAN.

19. Added support for custom DHCP Option on Switch 6.0 firmware in Device > Switch Details > 
Config > VLAN Interface > DHCP Server and Site > Network Config > LAN > VLAN > 
Add/Edit.

20. Added support for advanced Multicast configuration on Switch 6.0 firmware, integrating 
VLAN, switch, and port associations and enabling IGMP/MLD Snooping options, in Global > 
Network Config > Network Settings > LAN > Multicast and Device > Ports > Config > 
Multicast Fast Leave / Device Config > Switch > Switch Ports > Port Profile > Multicast 
Fast Leave.

21. Added support for STP Security on Switch 6.0 firmware in Site > Switch Details > Port Config 
and Device Config > Switch Ports > Port Settings / Port Profile.

22. Added support for /31 subnet masks on VLAN interfaces on Switch 6.0 firmware in Site > 
Switch Details > VLAN Interface and Site > Network Config > LAN > VLAN > Add/Edit.

23. Added support for Storm-Control with ratio configuration on Switch 6.0 firmware in Site > 
Switch Details > Port Config > Bandwidth Control and Device Config > Switch Ports > 
Port Profile > Bandwidth Control.

24. Added support for Controller hot-standby redundancy in Global > Settings > Cluster > Hot-
Standby Backup.



25. Optimized LACP behavior so member ports remain blocked until aggregation succeeds, 
shown in Device > Details > Ports List. 

26. Added support for adopting and managing the OLT-X2 model in Device > OLT Details > 
Config > System > Board Control, including board-level upgrading, rebooting, and 
configuration (firmware DS-MCUA1.1.0).

27. Added support for multi-channel OLT configuration, removing the restriction that prevented 
standalone UI access while under Controller management (supported on DS-P7001-04, DS-
P7001-08, DS-P8000-X2 with DS-MCUA ≥ 1.1.0).

28. Added support for OLT adoption and management in Controller cluster mode (all models, 
firmware production scheduled for 2025-Q3).

29. Added support for Network Check Tools—ping and traceroute—on OLT devices in Site > 
Network Tools > Network Check and Device > OLT Details > Tools > Network Check (all 
models and firmware versions).

30. Added support for Device Management to configure OLT devices in Global View > Settings > 
System Settings, compatible with models DS-P7001-04, DS-P7001-08, and DS-P8000-X2 (DS-
MCUA) firmware version 1.1.0.

31. Added support for spectrum scan in Device > AP Details > Statistics > Environment. (TCP 
port 29817 required)

32. Added support for interference detection in Device > AP Details > Statistics > Interference 
Detection and Site > Network Tools > Interference Detection. Currently, only EAP787 
devices will display the corresponding rectangular chart of Wi-Fi interference results. (TCP 
port 29817 required)

33. Added support for configuring Enhanced Open MLO SSID in Site > Network Config > 
Network Settings > WLAN, allowing MLO to be enabled when the encryption is set to None, 
effective for WiFi 7 devices.

34. Added support for stream-mode packet capture, also known as remote real-time packet 
capture, in AP Details > Tools > Packet Capture and in Site > Network Tools > Packet 
Capture. This feature allows users to remotely monitor AP device packet capture interfaces 
via Wireshark, displaying captured packets in real time to meet the needs of scenarios 
requiring live traffic analysis.

35. Added support for Probe Response Maximum Retransmission and Probe Response 
Threshold configurations in Site Setting > Wireless Features > Management Frame 
Control > Probe Response Maximum Retransmission/Probe Response Threshold (AP 
firmware should support these features).

36. Added support for adopting the Gateway 5G ODU model ER701-5G-Outdoor v1.0; 
configurations for IP-Passthrough mode reside in Device > Details, while standard routing 
mode settings are in Site View and Device > Device Details.

37. Added support for EoGRE Tunnel in Device Config > EAP > EoGRE Tunnel to enable SSID 
extension across physical locations.

38. Added support for custom logo uploads in voucher printing in Configuration > Hotspot > 
Voucher Groups > Create/Edit Voucher Pattern and Voucher Group > Edit Voucher.

39. Added support for the “Apply to all portals” option and daily usage limit for local users in 
Configuration > Hotspot > Local User.

40. Added support for overriding default LAN DHCP settings during adoption in Network Config 
> Network Settings > LAN > Default. 

41. Added support for user-invitation emails in 23 languages, auto-aligned with the user’s locale.



Original Location New Location

Performance Device Details

Switch Statistics Switch Details > Port

Application Analytics Dashboard > Traffic Insight > Application Analytics

42. Added support for single public-IP cross-NAT device adoption under Linux cluster mode in 
Settings > Cluster > Cluster Node List via configurable Device 
Management/Discovery/Monitor ports.

43. Added support for single public-IP cross-NAT device adoption in Linux cluster mode in 
Settings > Cluster > Cluster Node List > D**evice Management Port/Device Discovery 
PORT/DEVICE MONITOR PORT**, allowing multiple nodes to use a single public IP for device 
management by configuring mappings from discovery and management ports to different 
node IPs.

44. Added a new port 29817 for device management. Please ensure that this port is open in your 
firewall settings.

 

 

 

 

Enhancements  

1. Reorganized the Settings menu into Network Config and Device Config and added site-level 
configuration in the Device Details page.

2. Optimized UI with refreshed theme colors, tables, forms, icons, and charts

3. Optimized VLAN configuration process in Network Config > Network Settings > LAN**.** 
a) Streamlined setup into three steps: Network Parameter, Select Device Port, and 
Confirm/Apply. b) Adjusted the modification process to align with the new setup steps. c) 
Enhanced the network display interface with UI improvements.

4. Optimized Switch Port configuration by replacing Profile-based Native/Tag/Untag settings 
with per-port private configuration and introduced cross-device bulk management of Tag, 
Network, and Profile settings in Device Config > Switch Ports > Port Settings. 

5. Optimized Dashboard chart library with new Overview, Topology, Client, and Traffic tabs 
including AP Density & Activity charts in Site View > Dashboard. The original Dashboard 
custom dashboard function has been moved to Insight > Report.

6. Optimized the Statistics menu by relocating Performance to the device details page, Switch 
Statistics to the Switch details > Port, and Application Analytics to Dashboard > Traffic, 
Insights > Application Analytics.

The position changes of the original content are as follows:

7. Optimized Insights menu by: a) Adjusting the menu structure to separate operational data 
from statistical chart data. b) Merging statistical charts for a unified display. c) Placing 
configuration records on their respective settings pages.

The position changes of the original content are as follows
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Original Location New Location

Session Limit Gateway Details > Network View > Session Limit

Known Clients Clients

Past Connections Clients

Past Portal Authorizations Hotspot > Authorized Clients

Switch Status Configuration > Device Config > Switch > Switch Ports

Port Forwarding Status Gateway Details > Network View > Port Forwarding Status

VPN Status Configuration > Network Config > VPN > VPN Status

Routing Table Gateway/Switch Details > Network View > Routing Table

Dynamic DNS Gateway Details > Config > Advanced > DNS

Rogue APs Network Tools > Interference Detection

Threat Management Gateway Detail > Config > Network Security > IDS/IPS

QoS Data Gateway Detail > Network View > QoS Data

8. Optimized Reports framework with customizable tabs, card visibility/sort order, and multi-tab 
export in Site View > Insights > Reports.

9. Optimized Report export functionality to support simultaneous packaging and export of 
multiple tabs in Insights > Reports > Export > Export Report. (For Linux, users are required 
to manually install Chromium version 120.0.6098.0 or higher).

10. Optimized Logs by adding 30-day historical data filters in Logs > Alerts and Logs > Events, 
and relocating Audit Logs in Logs > Audit Logs, device-type filters in Logs > Settings > 
Alerts/Events > Content Settings, and Remote Logging in Logs > Settings > Advanced.

11. Optimized Rogue AP into Network-wide Interference Detection for batch scans and per-
device results in Site > Network Tools > Interference Detection. Currently, only EAP787 
devices will display the corresponding rectangular chart of Wi-Fi interference results.

12. Optimized wireless routing by displaying accurate maximum associated clients in Device > 
Wireless Router Details > Config > Wireless > Advanced and adding PPSK scaling in 
Network Config > Profile > PPSK.

13. Optimized table persistence to save user-defined pagination across sessions in Devices, 
Logs, Clients, and Device Config > Switch Ports > Port Settings. 

14. Added inline explanations for each role in Account > Role via tool tips displayed when 

hovering over the  icon.

15. Added support for VOIP module templating in Site Template > Network Config > VOIP.

16. Added display of the public IP for pending devices in Device List > Controller Connection IP.

17. Added Device Reconnected log type and offline-duration tracking in Site > Logs > Events > 
Device.

18. Added support for Switch syslog forwarding in Logs > Settings > Advanced when Client 
Details Logs is enabled.

19. Optimized default RSTP and loopback-detection settings in Device > Switch Details > Config 
> Services > Loopback Control.



20. Added edge-port risk warnings on STP configuration in Device > Switch Details > Port 
Config, in Device Config > Switch Ports > Port Settings, and in Device Config > Switch 
Ports > Port Profile.

21. Optimized Switch onboarding by enabling adoption via custom management VLAN and auto-
syncing related VLAN Interface, Port, and Static Route configurations in Device > Switch 
Details.

22. Added Remember Device support for switch stacks in Device > Stack Details > General.

23. Added routing table and OSPF neighbor display in Device > Switch Details > Network View.

24. Optimized VLAN Interface capacity beyond 16 entries, device-dependent, in Device > Switch 
Details > VLAN Interface. 

25. Added support for gateway capability warnings in Network Config > VPN, in Network 
Config > Security > URL Filtering > Gateway Rules, in Network Config > Security > 
Firewall > Attack Defense, in Device > Gateway > MAC Filtering, in Device > Gateway > 
Dynamic DNS, and in Device > Gateway > IPTV.

26. Optimized Portal IP auto-refresh behavior with manual input box in Global > Settings > 
System Settings > Access Config and in Site > Network Config > Authentication > Portal.

27. Added support for batch-adopt result pop-ups in Global > Device List > Add Device > Auto 
Find and in Site > Device List > Batch Action > Batch Adopt.

28. Optimized VLAN range expansion to 1-4094 for Switch/third-party devices and restricted to 1-
4090 when Gateway or its LAN port is selected in Network Config > Network Settings > 
LAN.

29. Added support for MSP customer limit increase to 500, customizable via omada.properties in 
MSP > Customer List.

30. Added support for site search in Global > Settings > Export Data.

31. Optimized temporary user permissions with risk warning in Accounts > User and in 
Accounts > SAML Role.

Bugs Fixed  

1. Fixed  load-balance ratio anomalies by auto-recommending optimal weights on WAN  port 
changes in Network Config > Network Settings > Internet.

2. Fixed  wired/wireless traffic statistics inaccuracies and added Internet  WAN-traffic charts in 
Reports > Summary > Traffic > All  Network, in Dashboard > Traffic > Traffic (All 
Network), in  Reports > Summary > Traffic > Internet, and in  Dashboard > Activity. 
(Traffic display may differ before and after  controller upgrade)

3. Fixed  SSID Summary Report missing traffic data for some APs in Report >  Wireless > Top 20 
SSIDs (Traffic).

4. Fixed  Dashboard traffic chart inconsistencies between “yesterday” and “last 24  h” selections 
in Report.

5. Fixed  search functionality for specific module tabs.

6. Fixed SSL  VPN certificate export failure when site name contains special characters  in 
Settings > VPN > VPN Settings > VPN > SSL VPN.

7. Fixed  duplicate descriptions on the ALG introduction page in Transmission  > NAT > ALG.

8. Fixed the  iOS Omada app overwriting Local Username and phone fields in Hotspot  > Local 
User.
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9. Fixed  Open API documentation mismatch for Get site switch 802.1x setting by  removing the 
“switches” parameter in Online Open API Document >  Authentication > Get site switch 
802.1x setting.

10. Fixed  CVE-2025-25193 by upgrading the Netty version to mitigate DoS attack risk.

Notes  

1. Please note that Controllers on different platforms may vary in features, even if their first 
three digits of the version code are the same. For example, the Linux Controller currently 
supports Cluster Mode but the Windows Controller doesn't support it yet.

2. The Omada SDN Controller can only manage certain devices running the supported 
firmware. Please confirm that your device is compatible with the SDN Controller.

3. Since version 5.14.32, the Omada Software Controller no longer supports upgrading from 
Controller v4.

4. To strengthen overall security, we recommend upgrading all devices to the latest firmware.    
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